How can we help?

Follow

I'm receiving an "Outdated Browser" error when attempting to purchase tickets

 

The Festival Ticketing shopping cart requires a minimum browser version to ensure that data is being processed securely. If you happen to receive an error when attempting to access a Festival Ticketing shopping cart, please ensure that your web browser of choice is updated to the latest version. If you would like to download the latest version of your browser, please visit http://browsehappy.com/ 

As of 1/10/17, these are the minimum required browser versions for most common web browsers:

 Google Chrome: 21
Android Browser: 4.1
Firefox: 23
Internet Explorer: 8
IE Mobile: 10
Opera: 8
Safari: 7
Safari Mobile: 5

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.

Pick your festival